Mbin Blog Updates

bluGill ,

arrgh, just hit report and submitted for spam, then realized I meant to report the post below the one I reported. Sorry about that, I don't see any undo.

Damaskox , (edited )
@Damaskox@kbin.social avatar

I receive an error when I'm trying to delete a comment.

EDIT: I tried deleting again later and I think the duplicated comment was gone.

ThatOneKirbyMain2568 ,
@ThatOneKirbyMain2568@kbin.social avatar

I've been doing a lot with userstyles and userscripts lately!

First, I've just released idkbin 1.3.7 and Dropdown Menu Icons 1.1.0, both of which add icons to the "more" button's dropdown menu.

Second, I made my first userscript: Improved Channel Select Menu! This is my first time making something with —a good bit of the code is based of raltsm4k's Floating Subs List—but I'm really happy with it! Earlier today, I released version 0.2.0 which adds a settings button and some new features. If you have any feedback, please share here.

Pamasich ,
@Pamasich@kbin.social avatar

@ernest
I've noticed this week that I'm currently seeing no visual indication that the boost button is active. No underline, color, or anything.
It seems that a now-broken userstyle I'm using expects there to be an "active" class applied to the element, but it isn't anymore. Is that intentional?
Figured I should point this out to you in case you don't know already.

ThatOneKirbyMain2568 ,
@ThatOneKirbyMain2568@kbin.social avatar

@Pamasich @ernest Can confirm that this is an issue. I brought attention to it a short while back, and there are also some bugs with the visuals for vote buttons not consistently working as they should.

ThatOneKirbyMain2568 , (edited )
@ThatOneKirbyMain2568@kbin.social avatar

Just learned that you can have dropdowns in Stylus settings, and I've implemented that in idkbin 1.3.5! Now you can choose from both of the "more" icons I was considering, among many other new options.

View the changelog here.

ThatOneKirbyMain2568 ,
@ThatOneKirbyMain2568@kbin.social avatar

Implemented menu icons in idkbin 1.3.6! They make the UI feel a lot more polished imo.
I also made these a standalone userstyle if you just want those.

genesis ,
@genesis@kbin.social avatar

Why are the microblogs not working properly?

testing ,
@testing@kbin.social avatar

@genesis i get your question! what does annoy you the most?

Damaskox ,
@Damaskox@kbin.social avatar

I still keep losing comments.
Stuff pointing from notifications lead to no such comment - cannot find anything with Ctrl+F and I see no page numbers or any other indicators of any other pages existing.

ThatOneKirbyMain2568 , (edited )
@ThatOneKirbyMain2568@kbin.social avatar

idkbin 1.3.4 is out! This time around, I added a small icon next to the expand/collapse button on microblog posts. Like with most things in idkbin, it can be toggled.

View the changelog here.

ernest ,
@ernest@kbin.social avatar

@testing Can you repeat your tests regarding tags between kbin and other instances? It should be significantly better ;)

testing ,
@testing@kbin.social avatar

@ernest
thank you! tags from kbin do federate on microblogging fedi - kbin users should use the the tags section rather than the text body though

  1. i also had a look at friendica; sadly, friendica seems not to be capable to pick up tagged posts from kbin > see e.g. https://friendica.opensocial.space/search?tag=kbin > tried my luck at several friendica instances, and every time: no content from kbin
  2. tags in kbin threads do not display on kbin pwa, e.g. https://kbin.social/m/kbinDevlog/t/692551 > on microblogging fedi platforms, i can see three tags: kbin, fediverse, and kbinDevlog for the magazine > with kbin pwa, neither kbin nor fediverse show up
ernest OP ,
@ernest@kbin.social avatar

@testing Thanks for the summary. I will check those cases.

Damaskox ,
@Damaskox@kbin.social avatar

Anyone else not being able to find their comment in a thread?
I have a notification of two replies but I cannot find even my own comment let alone their replies.

Damaskox OP ,
@Damaskox@kbin.social avatar

@livus Didn't see any page indicators.
Clicked oldest and still didn't find by searching my nickname.

ernest ,
@ernest@kbin.social avatar

@Damaskox Could you send me the URL from the notification via private message, please?

ThatOneKirbyMain2568 ,
@ThatOneKirbyMain2568@kbin.social avatar

idkbin has been updated to 1.3.3! The more button has been replaced with an ellipsis, and the no avatar icon has been changed.

And I fixed more sort icon issues. Again. I'm really bad at this.

View the changelog here.

ThatOneKirbyMain2568 ,
@ThatOneKirbyMain2568@kbin.social avatar

idkbin 1.3.2 is out! This fixes a couple of bugs and adds a placeholder icon in the comments for people without an avatar. Before, it was just an empty box, so I figured it'd be nice to have something to fill it.

View the changelog here.

jwr1 , (edited )
@jwr1@kbin.social avatar

@ernest, I just have a quick question. Looking at the kbin oauth documentation on codeberg and swagger, I got the impression that an authorization client needs to be registered on a server before a user can start using the API. This would be fine if kbin weren't federated, but what if a user wants to sign in to a different instance that doesn't have the oauth client I set up? Basically, I'm asking if there's a way to use the API without setting up the oauth client, but still be able to login to an account. Thanks

sudo_xe , (edited )
@sudo_xe@fedia.io avatar

Seeing no ''index.php'' in URLs for mbin's (flagship?) instance here in the form of https://kbin.melroy.org/m/updates/microblog nor for any kbin ones, but they're coming up in Fedia i.e. https://fedia.io/index.php/m/updates@kbin.melroy.org/microblog

Intriguing...


Edit: and now it's resolved here but I'm seeing it manifest on kbin.social??

  • All
  • Subscribed
  • Moderated
  • Favorites
  • random
  • updates
  • programming
  • tech
  • testing
  • marketreserach
  • drbboard
  • til
  • wanderlust
  • bitcoincash
  • Sacramento
  • All magazines